Sunday, March 24, 2013

Ubuntu Precise & Nvidia/ATI displays

Installing Ubuntu 12.04 LTS on VirtualBox when the host machine has Nvidia graphics drivers poses a bunch of problems - black screens, graphics failures and the desktop just not showing up. Primarily, this is because Ubuntu doesn't by default come with drivers that work with these (Nvidia/ATI) graphics cards.

After a few attempts, I poked around Google and came up with a few suggested actions that ended up working.

A very detailed explanation of the available courses of action is available here:

My specific problem turned out to be a black screen accompanied by a few error messages before it defaulted to a command line login. The solution, as suggested by the link, was to edit the grub file and add "nomodeset" to the boot up options. I did this but it still didn't work out as expected.

More googling led me to this link where the author explains how to get the latest nvidia drivers

10 minutes later I see the Ubuntu desktop! Success and I think I'm getting good at this linux stuff. I play around a bit and restart the VM. To my surprise I see a black screen with more errors. Back to google me thinks. This time around I found out that updating the grub file only affects that boot instance and a few additional steps are required to "remember" these changes during every boot.

A reboot later, I see the Ubuntu desktop. With great expectation, I reboot a couple of times and each time the Ubuntu desktop comes up without a hitch.

Linux is easy. With Google :)

Edit 1: I tried this on a laptop with Intel HD4000 display drivers and it went without a hitch - just a plain install from the iso, reboot and all is good. No issues with drivers etc

No comments: